Hatena::Groupsubtech

ういはるかぜの化学

Thursday, March 10, 2011

[] .zshrc で特定のバージョン以上なら…と書くには 21:55  .zshrc で特定のバージョン以上なら…と書くには - ういはるかぜの化学 を含むブックマーク はてなブックマーク -  .zshrc で特定のバージョン以上なら…と書くには - ういはるかぜの化学

がんばって条件判定あーでもないこーでもないって探してあきらめたのち、たまたまis-at-leastっていうのがあるのを知りました

autoload -Uz is-at-least
if is-at-least 4.3.10; then
    # http://subtech.g.hatena.ne.jp/secondlife/20110222/1298354852
    # zsh 4.3.10 以降じゃないと動かないと思う
    bindkey '^R' history-incremental-pattern-search-backward
    bindkey '^S' history-incremental-pattern-search-forward
fi

ちなみに最初はこう書いてた…

if zle -la history-incremental-pattern-search-backward; then
    ...
fi

むずかしいお。

トラックバック - http://subtech.g.hatena.ne.jp/mayuki/20110310